Search Results

Search results 1-20 of 27.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Haha, So I figured it out because I was over it not running. I cranked that thing for awhile then finally the pcm threw iac code, I was able to get it to fire up before I replaced sensor. I ended up changing the tps as well because it was having long cranks to fire up. Now I think I need to check injectors cus when I prime fuel lines my pressure drops to zero. It has a new pump assembly so I’m trying to figure out how to test just from the quick connect back to tank to make sure leak is in rail …

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Looks like we were ALL WRONG. Not the fuel pump, had two new ones put on. Not the crank nor cam shaft sensors, had new of each put on. Not the relays had new asd and fuel pump relays installed. Not the wiring to pump, was correct as I said. Turns out a stuck idle air control valve can cause a crank no start.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    The Jeep cranks just won’t fire.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    forgot to mention I can jumper the fuel pump relay and get the pump to run continuously. I tried to jumper ads relay and it still would not run.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Daddanelena, I saw your original post about that, the reason I believe we have different issues is this Jeep ran with first new fuel pump I put in, I had to rebuilt bottom end due to stuck rings and cracked pistons. After the rebuild it fired up and ran for 15 minutes or so then I turned it off and have not gotten it to turn back on. I switched the list of parts fuel pump crankshaft cam shaft sensors relays and it is still sitting. Thanks for the advice tho.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Astape, It has spark, and fuel for first few seconds when key is turned on. It seems to not have the 5volts to the injectors.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Thanks Meeper, I was trying to hold out on pcm being they are costly. You mentioned a used one, may I ask why you say used... would reman or new work?

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Confirmed spark... pulled plug wire hooked up loose spark plug grounded to motor turned key. Watched spark plug fire twice stopped turning key. Tach no bouncing... replaced both distributor and crankshaft sensors. Leads me back to pcm. However the check engine like lights up and turns off after a few seconds. Fuel injectors are not getting 5volt power. Ever. Leads me back to pcm. I’m working on checking all grounds and wires now. So far everything looks great.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Update: I found the IOD fuse. It should be a 10 amp, looks like previous owner put in a 20 Amp? I’m guessing I should put back in a 10Amp. You think that could of fried something being it couldn’t blow at 10 Amps if it needed to? -Matt

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Astape, 1) Check engine light comes on when key turned to start. Turns off after a few seconds. 2) The tach DOES NOT bounce when cranking motor over. 3) Looking for the IOD fuse. What does that stand for if you don’t mind. 4) I have the under hood fuse box detached everything under it is attached and no brakes or burns. I’m looking through the service manual I found online to figure out how the fuel injectors get power. I have crank, fuel at least to rail and spark. I believe I have no power to …

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Hey Astape, I’m wondering if you know of any information out there about ways to bypass the ASD circuit. I’m beginning to believe whatever issue I have is in the asd. I say that because I don’t have power to fuel pump when cranking engine over. Also looks like I do not have the 5volt supply to injectors as well. Thanks again

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    No worries I appreciate the input. I pulled the asd relay and numbered from 12volt supply to center wire. Tried to start it didn’t fire. I read that means it’s either crank or camshaft sensors. The camshaft sensor is the disc inside distributor correct? I’ll install the jumper as you said off fuel pump today. Thanks again.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Fun update: just put a 2nd new fuel pump 2 new relays fuel pump and asd Crankshaft position sensor. Not sure what else I guess some injectors for fun... jeep life haha

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    Thanks, So I was able to push in the schrader valve(stem) on the fuel rail and turn the key and gas went everywhere. When I cycle the key like you said just on not started; and checked again at Schrader stem no pressure. The only way i can get fuel to the rail is by holding in Schrader stem and turn key to on not start. As far as the feed hose coming loose i did end up dropping the tank just so i could have a better look at things. I have a question you might know something about; the gas tank h…

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    This pump is only 25 minutes run time old, I’m guessing you have experience with new pumps going bad even after it just ran the vehicle. Guess I’ll buy a new one. The crank position sensor doesn’t tell the pump when to send fuel? I’m just struggling with a brand new pump being bad. I guess it could happen and it would happen to me. Cheers astape thanks for the reply

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    I realize that last message was confusing. I do not have pressure at the fuel rail. I pulled the connection off at fuel pump and I have a hot to ground (frame with test light) but that’s about all I can come up with. I can hear the pump kick on, at least it sure sounds like the pump. Odd

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    I do in fact not have fuel pressure at the rail. I had it running and shut it down, now it wont start back up, I've done the turn the key let it prime a handful of times and get little to no pressure at the rail.

  • Troubleshooting fuel system, no start

    Matt - - Jeep Talk

    Post

    I have been rebuilding a 1997 TJ over the last couple months, I got the motor back together and finally fired up last night. I turned the engine off and went to start it again and it cranks but does not fire. I have a new fuel pump in it and have checked that injectors work, replaced the few that were not functioning. I crawled under the jeep and noticed the "Fuel return Evap Line" looks to be rusted and wet over top of the rear spring mount. I guess I'm wondering if that evap return line could …

  • TJ parts

    Matt - - Swap Meet (Jeep Stuff)

    Post

    Long shot but are you still parting the 97 TJ out?

  • Do you still have the motor Meeper?